ApplicationSuite.PreInstallTool or ApplicatioSuite.PreUpgradeTool crashes upgrading from 2013.Winter.1 or previous
Article ID: 664
Last updated: 17 Jul, 2019
Applies from Application Suite 2018.6.1
to version Application Suite 201x (any version)
Description
When upgrading from IAS version 2013.Winter.1 (2014.1.1) or previous, the setup fails showing one of the following error messages:
ApplicationSuite.PreInstallTool has stopped working
or
ApplicatioSuite.PreUpgradeTool has stopped working
Cause
ApplicationSuite.PreInstallTool is trying to read the installed version on the registry, but it is written in an obsolete form that it cannot parse.
Solution
Locate the following key in the Windows Registry:
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\StonevoiceApplicationSuite_is1\DisplayVersion
and set it to the <year>.<season>.<build> representation of the current value. For instance, IAS Winter 2013 build 1 would set that key to "2014.1 (build #1)". In that case, you need to set the key to "2014.1.1".
After changing the registry key, you can run the setup again.
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