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Avoiding media forking calls refusal for calls that do not have to be recorded

Article ID: 641
Last updated: 28 Jan, 2019
to version Application Suite 201x (any version)

Applies to

IAS Winter 2019 or newer

Description

It is now possible to configure Imagicle Call Recording to avoid call rejection to CUCM with error 403.

Cause

This typically happens when a MediaForking or SIPREC recording is rejected due to a filter option (call direction, traffic type, blacklisted remote party). 

Call Recorder can now respond to the call without registering it. After a configurable timeout, recorder hangs up the call.

Solution

This option is disabled by default. In order to activate it, head to Apps\Recorder\Settings\Recorder.ini file (no need for recorder restart) and:

  • AnswerRefusedCallBecauseOfFilters: set to 1 to activate this option, 0 to return to the traditional one;
  • HangUpRefusedCallBecauseOfFiltersTimeout: number of seconds after which the response call, whose recording has not been started, is hung up by the recorder. By default this parameter is 2  and is used only if the previous parameter is 1. It is suggested to keep this value low to minimize channels occupation by calls that have not to be recorded

on Sql management studio issue the following query command:

USE [master]

CREATE LOGIN [imagicleUser] WITH PASSWORD=N'imagiclePassword',DEFAULT_LANGUAGE=[us_english],CHECK_EXPIRATION=OFF,CHECK_POLICY=OFF

GRANT CONNECT SQL TO [imagicleUser]

GRANT CREATE ANY DATABASE TO [imagicleUser]

GRANT VIEW ANY DATABASE TO [imagicleUser]

NOTE. 

It is recommended to use this mode of recording rejection only where necessary, continuing to use the previous mode in case of no issue.

In fact, this option that always responds requires more resources: i.e channels are required alsofor calls that are not to berecorded, at least either for the time they are hung up or when the timeout expires (the event happening before).

Article ID: 641
Last updated: 28 Jan, 2019
Revision: 1
Views: 478
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