Wrong name and visibility for Contact Manager local directory

Applies to

Imagicle Application Suite 2017.Summer.2 or 2017.Summer.3 - installed from scratch

Description

An installation from scratch of 2017.Summer.2 or 2017.Summer.3  will have a pre-defined Contact Manager configuration that:

Cause

The configuration file <StonevoiceAS>\Apps\Speedy\Settings\Speedy.Configuration.Global.config.xml contains wrong pre-defined values, instead an empty config.
 

Solution

  1. Edit file <StonevoiceAS>\Apps\Speedy\Settings\Speedy.Configuration.Global.config.xml" and remove the following preference keys:
    • "directory.internalsdefaultdirname"
    • "directory.LocalDirectorySpecialDepartment"
    • "directory.ExcludeThisUsernameFromLocalDirectories"
       
  2. Edit file <StonevoiceAS>\Apps\Speedy\Server\System\Speedy.ini" and delete the following keys from section [Settings]:
    • internalsdefaultdirname
    • LocalDirectorySpecialDepartment
    • ExcludeThisUsernameFromLocalDirectories
       
  3. Update directories content, following these steps:
    • Login to the IAS web portal as administrator and go to Contact Manager, Manage Service web page
    • Locate the "Internal contacts settings" section and change the radio button value. Click Save. This will start the local contacts update procedure, that may take some seconds.. 
    • Reload the page until the radio button becomes enabled (the local contacts update completed)
    • Change again the radio button value, back to the original value. Click Save.


Article ID: 511
Last updated: 09 Aug, 2021
Revision: 10
Imagicle AppSuite Cross Platform -> Contact Manager -> FAQ and Solutions -> Wrong name and visibility for Contact Manager local directory
https://kbp.imagicle.com/kb/entry/511/