AXL not working correctly - Error Nr. -2147012894 and user are not synced with error [GetData] Operation too long

Applies to

Application Suite: any version 

Description

AXL is not working correctly

Users sync fails with error: Interrupt -> Internal rule's Exception (Pbx): [GetData] Operation too long (05:00:00.0630527), aborting. --> No Parent exception

You can see in the log file <StonevoiceAS>\Var\Log\SvSasAXL.log_XXXXX some errors like:
Error Nr. -2147012894 Timeout dell'operazione
or
Error detecting CM family (438): Object doesn't support this property or method
or
Status after request: Proxy Error ( Forefront TMG denied the specified Uniform Resource Locator (URL))
 

Cause

The system is configured to have WinHTTP use a proxy

Solution

Verify the configuration of WinHTTP (Microsoft Windows HTTP Services) on the server.
From a elevated command-prompt:

Check if WinHTTP is configured:
netsh winhttp show proxy

Reset WinHTTP configuration:        
netsh winhttp reset proxy
Or
delete the two registry keys:
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\WinHttpSettings
HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\WinHttpSettings

Restart Imagicle AXL client in Windows Service Panel

Microsoft documentation here:
https://msdn.microsoft.com/en-us/library/windows/desktop/aa384069%28v=vs.85%29.aspx?f=255&MSPPError=-2147217396 



Article ID: 616
Last updated: 22 Apr, 2020
Revision: 2
Imagicle UC Suite for Cisco UC -> FAQ and Solutions -> AXL not working correctly - Error Nr. -2147012894 and user are not synced with error [GetData] Operation too long
https://kbp.imagicle.com/kb/entry/616/