How to assign a recorded conversation to the final call recipient

to version Application Suite 201x (any version)

Applies to

IAS 2020.Spring.1 or newer

Description

A new Call Recording setting allows to correlate an incoming, recorded call to the final operator who handled the call.

Cause

While using SIPREC recording method, with incoming calls reaching operators through an IVR, it happens that relevant recorded conversation is associated to IVR pilot number or to the first operator involved in the call. Customer wants to see the call associated to the final operator who actually handled the call instead. 

Solution

A new parameter is available in this setting file:

C:\Program Files(x86)\StonevoiceAS\Apps\Recorder\Settings\Recorder.ini

This parameter controls Cisco SIPREC behaviour: AllowRecordableCallInfoUpdates and it can assume two different values:

See below sample, where the first call (REC ID 2020...06) has been answered and handled by User "u259" with ext. #259, while second call (REC ID 2020...07) has been forwarded to User "u259" and eventually answered and handled by ext. #9999.

Troubleshooting notes



Article ID: 739
Last updated: 30 Mar, 2020
Revision: 1
Imagicle UC Suite for Cisco UC -> Call Recording -> FAQ and Solutions -> How to assign a recorded conversation to the final call recipient
https://kbp.imagicle.com/kb/entry/739/