BillyBlues Alarms are not reliable or not correctly executed

Applies from Application Suite 2014.12.1
to version Application Suite 201x (any version)

Applies to

All Billy Blue's  version

Description

A Billing alarm could not be triggered when it is related to calls made near the alarm execution time.

Cause

Unfortunately BillyBlues cannot import calls in real time!
The time between the end of the call and the time when the call will be visible on billiblues depends on many factors, ranging from the type of PABX to the server workload, This time can vary from a few seconds to a few tens of minutes.

The alarm is not able to examine calls that have already been terminated but have not yet been imported.

By default the alarms manager assume that less than 5 minutes are required to receive and import the calls.

For example, let's assume that on a particular billyblues customer it takes 15 minutes to make calls available,
and the customer setup an alarm for calls to a specific number (911) executed every 5 mins:
This alarm will never be triggered!!

When the alarm is executed, it try to search a call made in the last 5 mins, to 911, but this calls are not yet in the db. If the alarm start at 10:00, it search for calls made from 9:50 to 9:55 (5 minutes shifted), finding 0 calls; then at 10:05 it search for calls made from 9:55 to 10:00 and so on.

Solution

We can shift manually the searching interval writing in blues2000.ini the number of minutes to switch
editing the BluesAlarmPeriodDelay parameter.

here an example, to shift 30 minutes backwards

[Configurazione]
...
BluesAlarmPeriodDelay=30


Article ID: 807
Last updated: 14 Jan, 2021
Revision: 1
Imagicle UC Suite for Cisco UC -> Call Analytics -> FAQ and Solutions -> BillyBlues Alarms are not reliable or not correctly executed
https://kbp.imagicle.com/kb/entry/807/