AXL blanks users data if ImagicleCTI CUCM Application User does not have the correct permission and the AXL process can hang

Applies to

Imagicle AppSuite for Cisco UC

Description

Users already configured and working might randomy be found without fields such as the extension number, email, mac address etc.

This will in turn cause various issues with the AppSuite components, eg. calls not being recorded, faxes not working, wrong or missing budgeting in Billy Blues, inability to login to the attendant console, inability to lock or unlock a phone with StoneLock, inability to receive calls from the Queue Manager, wrong budgeting in Budget Control, etc.

Cause

The problem lies in the lack of the correct permissions set for the user that the IAS is using to communicate with the Cisco Unified Communications Manager (CUCM), errors from the AXL service overtime will cause the AXL client to hang and blank those fields, the user sync will then blank the users proprieties.

The issue is observable by running an SQL query on an affected user:

SELECT * FROM [IAS].[dbo].[CCMUsers] WHERE userid = 'Dep1User'

userid,firstname,lastname,telephonenumber,department,enablemobility,associatedDevice1,associatedDevice2,associatedDevice3,associatedDevice4,associatedDevice5,associatedDevice6,macaddress,primaryextension,deletedtimestamp,title,middlename,facsimiletelephonenumber,mailid,homephone,building,mobile,ocsprimaryuseraddress,site,partition,Tel_Id,Pager,Manager,DisplayName,DirectoryUri
Dep1User,NULL,NULL,NULL,NULL,0,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,User,NULL,NULL,Dep1User@domain.com,NULL,NULL,NULL,NULL,NULL,NULL,1,NULL,Dep1Manager,NULL,NULL

Restarting the Imagicle AXL Client service and letting it perform a new sync, then re-running the query will display the user correctly again:

userid,firstname,lastname,telephonenumber,department,enablemobility,associatedDevice1,associatedDevice2,associatedDevice3,associatedDevice4,associatedDevice5,associatedDevice6,macaddress,primaryextension,deletedtimestamp,title,middlename,facsimiletelephonenumber,mailid,homephone,building,mobile,ocsprimaryuseraddress,site,partition,Tel_Id,Pager,Manager,DisplayName,DirectoryUri
Dep1User,Dep1,User,1001,Dep1,1,SEPXXXXXX,CSFXXX,SEPXXXXX,NULL,NULL,NULL,XXXXXXX,10001,NULL,User,NULL,NULL,Dep1User@domain.com,NULL,NULL,NULL,NULL,NULL,PT_Dep1Users,1,NULL,Dep1Manager,NULL,NULL

The issue is also observable by:

Solution

On the CUCM, apply all every and only the correct permissions on the Application User used by the IAS as outlined in the CuCM CTI Configuration



Article ID: 811
Last updated: 23 Dec, 2021
Revision: 2
Imagicle UC Suite for Cisco UC -> FAQ and Solutions -> AXL blanks users data if ImagicleCTI CUCM Application User does not have the correct permission and the AXL process can hang
https://kbp.imagicle.com/kb/entry/811/