Advanced Queuing report failure due to out of memory

Affecting: 

Imagicle UC Suite rel. 2022.Summer.1.h1 and before

Description:

When you launch an Advanced Queuing report for a large time interval, it might happen you get an "out of memory" warning after a long waiting time.

Cause:

Report needs to retrieve a large amount of data from SQL and eventually the report transaction times-out.

Solution:

Starting from Imagicle 2022.Summer.1.h2 and above. two new parameters have been added in the following setting file:

C:\Program Files (x86)\StonevoiceAS\Apps\QME\Settings\QME.Engine.config.xml

Within this file, you can add the following statement:

<preference key="qme.report.callList.maxCallsCount" value="nnn"/>

Where nnn is the maximum number of lines to display within the report. Default value is 30000.

Another important parameter you can tweak is the following:

<preference key="qme.report.aggregatedReportsMaxCallDetailsCount" value="nn"/>

Where nn is the maximum number of calls to show in Advanced Queuing aggregated reports, when "Show details" is enabled. Default value is 100.

As you notice, both parameters are limiting the amount of data to retrieve from SQL DB, thus avoiding time-out or memory overload.



Article ID: 941
Last updated: 23 Jan, 2023
Revision: 3
Imagicle UC Suite for Cisco UC -> Advanced Queueing -> FAQ and Solutions -> Advanced Queuing report failure due to out of memory
https://kbp.imagicle.com/kb/entry/941/