Knowlege base

Unable to retrieve recordings (new installation)

Article ID: 516
Last updated: 01 Dec, 2017
Applies from Application Suite 2017.6.2
to version Application Suite 2017.6.3

Applies to

Imagicle Application Suite 2017.Summer.2 or 2017.Summer.3 - installed from scratch
 

Description

When a standard "User" try to open recording web page it receives:

"Unable to retrieve recordings. Please try again"

While the Administrator user can see web page and all records without any error.

Looking at "<StonevoiceAS>\var\log\w3wp\recorder.log" log file it is possible to observe this exception:
 

Exception Type {Speedy.Core.Common.SvOperationFailedException} 
Message {FindContactsByPhoneNumber: exception occurred} 
StackTrace { 
at Speedy.Directory.Api.SvDirApi.ReverseLookup(ISet`1 phoneNumbers, IContactInfoFinderSettings settings) 
at ApplicationSuite.Web.Helper.WebRequestAwareContactInfoFinder.ReverseLookup(ISet`1 phoneNumbers, ContactInfoFinderSettings settings) 
at Speedy.Directory.Api.ReverseLookup.ReverseContactLookup.<>c__DisplayClass11_0.<Lookup>b__1(ISet`1 numbersToSearch) 
at Speedy.Directory.Api.ReverseLookup.ReverseContactLookup.LookupMultipleNumbers(IEnumerable`1 phoneNumbers, Func`2 contactSearchFunc) 
at Speedy.Directory.Api.ReverseLookup.ReverseContactLookup.Lookup(String userName, IEnumerable`1 phoneNumbers) 
at Speedy.Directory.Api.ReverseLookup.ReverseContactLookupWithCache.<>c__DisplayClass13_0.<Lookup>b__1(IEnumerable`1 cacheMisses) 
at Speedy.Directory.Api.ReverseLookup.ReverseContactLookupWithCache.Lookup(IEnumerable`1 phoneNumbers, Func`2 createCacheKey, Func`2 lookupCacheMisses) 
at Speedy.Directory.Api.ReverseLookup.ReverseContactLookupWithCache.Lookup(String userName, IEnumerable`1 phoneNumbers) 
at Recorder.Engine.Recordings.RecordigsWithContactsRepository.LookupContactsForMultipleCalls(PagedResult`1 recordings) 
at Recorder.Engine.Recordings.RecordigsWithContactsRepository.GetRecordingsBase(ISearchCriteria options, Func`2 action) 
at Recorder.Engine.Recordings.RecordigsWithContactsRepository.GetRecordings(ISearchCriteria options) 
at Recorder.WebServices.RecordingsBrowser.GetRecordingsWebMethod.Execute(String username) 
at ApplicationSuite.Base.Library.WCF.WebService.Execute[TReturn](IWebMethod`1 webMethod)} 
InnerException { 
Exception Type {NHibernate.QueryException} 
Message {An empty parameter-list generate wrong SQL; parameter name 'directories'} 
StackTrace { 
at NHibernate.Impl.AbstractQueryImpl.SetParameterList(String name, IEnumerable vals, IType type) 
at NHibernate.Impl.AbstractQueryImpl.SetParameterList(String name, IEnumerable vals) 
at ApplicationSuite.Data.NhEntities.Sas.Speedy.SvContactDao.InternalFindContacts(IEnumerable`1 directories, IEnumerable`1 phoneNumbers, IEnumerable`1 phoneNumberFields, Boolean findInlocalContactsOnly) 
at ApplicationSuite.Data.NhEntities.Sas.Speedy.SvContactDao.FindContactsInDirectoriesByPhoneNumbers(IEnumerable`1 directories, IEnumerable`1 phoneNumbers, IEnumerable`1 phoneNumberFields) 
at Speedy.Directory.Api.SvDirApi.ReverseLookup(ISet`1 phoneNumbers, IContactInfoFinderSettings settings)} 

}}, StatusCode

Cause

The configuration file <StonevoiceAS>\Apps\Speedy\Settings\Speedy.Configuration.Global.config.xml contains wrong pre-defined values, instead an empty config.

Solution

  1. Edit file "<StonevoiceAS>\Apps\Speedy\Settings\Speedy.Configuration.Global.config.xml" and remove the following preference keys:
    • "directory.internalsdefaultdirname"
    • "directory.LocalDirectorySpecialDepartment"
    • "directory.ExcludeThisUsernameFromLocalDirectories"
       
  2. Edit file "<StonevoiceAS>\Apps\Speedy\Server\System\Speedy.ini" and delete the following keys from section [Settings]:
    • internalsdefaultdirname
    • LocalDirectorySpecialDepartment
    • ExcludeThisUsernameFromLocalDirectories
       
  3. Update directories content, following these steps:
    • Login to the IAS web portal as administrator and go to Speedy, Manage Service web page
    • Locate the "Internal contacts settings" section and change the radio button value. Click Save. This will start the local contacts update procedure, that may take some seconds.. 
    • Reload the page until the radio button becomes enabled (the local contacts update completed)
    • Change again the radio button value, back to the original value. Click Save.

Article ID: 516
Last updated: 01 Dec, 2017
Revision: 4
Views: 332
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