Unable to retrieve recordings
Applies to
Imagicle Application Suite up to 2018.Winter.1
Description
When a standard "User" try to open recording web page it receives:
- Unable to retrieve recordings. Please try again
While the Administrator user can see web page and all records without any error.
Looking at "<StonevoiceAS>\var\log\w3wp\recorder.log" log file it is possible to observe this exception:
Exception Type {Speedy.Core.Common.SvOperationFailedException}
Message {FindContactsByPhoneNumber: exception occurred}
StackTrace {
at Speedy.Directory.Api.SvDirApi.ReverseLookup(ISet`1 phoneNumbers, IContactInfoFinderSettings settings)
at ApplicationSuite.Web.Helper.WebRequestAwareContactInfoFinder.ReverseLookup(ISet`1 phoneNumbers, ContactInfoFinderSettings settings)
at Speedy.Directory.Api.ReverseLookup.ReverseContactLookup.<>c__DisplayClass11_0.<Lookup>b__1(ISet`1 numbersToSearch)
at Speedy.Directory.Api.ReverseLookup.ReverseContactLookup.LookupMultipleNumbers(IEnumerable`1 phoneNumbers, Func`2 contactSearchFunc)
at Speedy.Directory.Api.ReverseLookup.ReverseContactLookup.Lookup(String userName, IEnumerable`1 phoneNumbers)
at Speedy.Directory.Api.ReverseLookup.ReverseContactLookupWithCache.<>c__DisplayClass13_0.<Lookup>b__1(IEnumerable`1 cacheMisses)
at Speedy.Directory.Api.ReverseLookup.ReverseContactLookupWithCache.Lookup(IEnumerable`1 phoneNumbers, Func`2 createCacheKey, Func`2 lookupCacheMisses)
at Speedy.Directory.Api.ReverseLookup.ReverseContactLookupWithCache.Lookup(String userName, IEnumerable`1 phoneNumbers)
at Recorder.Engine.Recordings.RecordigsWithContactsRepository.LookupContactsForMultipleCalls(PagedResult`1 recordings)
at Recorder.Engine.Recordings.RecordigsWithContactsRepository.GetRecordingsBase(ISearchCriteria options, Func`2 action)
at Recorder.Engine.Recordings.RecordigsWithContactsRepository.GetRecordings(ISearchCriteria options)
at Recorder.WebServices.RecordingsBrowser.GetRecordingsWebMethod.Execute(String username)
at ApplicationSuite.Base.Library.WCF.WebService.Execute[TReturn](IWebMethod`1 webMethod)}
InnerException {
Exception Type {NHibernate.QueryException}
Message {An empty parameter-list generate wrong SQL; parameter name 'directories'}
StackTrace {
at NHibernate.Impl.AbstractQueryImpl.SetParameterList(String name, IEnumerable vals, IType type)
at NHibernate.Impl.AbstractQueryImpl.SetParameterList(String name, IEnumerable vals)
at ApplicationSuite.Data.NhEntities.Sas.Speedy.SvContactDao.InternalFindContacts(IEnumerable`1 directories, IEnumerable`1 phoneNumbers, IEnumerable`1 phoneNumberFields, Boolean findInlocalContactsOnly)
at ApplicationSuite.Data.NhEntities.Sas.Speedy.SvContactDao.FindContactsInDirectoriesByPhoneNumbers(IEnumerable`1 directories, IEnumerable`1 phoneNumbers, IEnumerable`1 phoneNumberFields)
at Speedy.Directory.Api.SvDirApi.ReverseLookup(ISet`1 phoneNumbers, IContactInfoFinderSettings settings)}
}
}}, StatusCode
Cause
The user logged in the Application suite is not authorized to see any directories
Solution
The bug has been fixed in IAS to 2018.Winter.1.
Without upgrading Application Suite, a workaround can be applied: just create a public directory or a department one available to the user.
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