IVR Module for QME - Scheduled Reports Export Error
Article ID: 548
Last updated: 22 Jan, 2018
Applies from Application Suite 2018.1.1
to version Application Suite 2018.1.1
Applies to
Imagicle Application Suite 2018.1.1
Description
In Auto Attendant | Scheduled Reports | "Last message" field shows "Export Error" and the scheduled report is not sent.
In the log file ( <StonevoiceAS>\Var\Log\ApplicationSuite.Core.Service\QME.log ) you can find the error:
0116 00:42:06.177 ERROR { 49} [ScheduledReportTaskBase] Unable to complete report
System.ArgumentOutOfRangeException: Unexpected report name: TimePeriodAnalysisReport
Parameter name: dataSetName
at QME.Data.Plugins.IvrReport.GetReportData(String dataSetName, ReportFilterBuilder filters, GroupByTimeInterval groupByTimePart)
at QME.Data.Plugins.IvrReport.GetDataTable(String dataSourceName, ReportDescriptor reportDescriptor, IReportBuilder reportBuilder)
at FW.Scheduler.Service.ScheduledReportTaskBase.GetDataTables(IEnumerable`1 dataSourceNames, ICollection`1 detailsDataSets, IReportBuilder reportBuilder, ReportDescriptor reportDescriptor)
at FW.Scheduler.Service.ScheduledReportTaskBase.GetDataTables(IReportBuilder reportBuilder, ReportDescriptor reportDescriptor)
at FW.Scheduler.Service.ScheduledReportTaskBase.ProcessReport(IasScheduledReport task, CultureInfo cultureInfo, ISvMessageSourceBase messageSource)
at FW.Scheduler.Service.ScheduledReportTaskBase.Execute(IasSchedule offlineSchedule)
Cause
Bug in the Application Suite version 2018.1.1
Solution
Apply the patch in attachment:
1. Stop "Imagicle Service Host" Windows service
2. Unzip the content into <StonevoiceAS>, overwriting existing files
3. Restart the service
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This article was: |
Attached files | |
2018.1.1-Ivr4QME-FixScheduledExecutionsOfTrendsReport-#10917.zip (14 kb) |
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